Scott Kitterman
118e854889
- Clarify the crlf does not count towards line length in fold
...
(LP: #1823008 )
2019-04-13 15:05:04 -04:00
Scott Kitterman
c1fec1cca8
Delete obsolete .IX macro from man pages
2019-02-08 01:18:12 -05:00
Scott Kitterman
0555cb595d
ChangeLog engry for jbfzs/beautifold
2018-12-23 01:57:38 -05:00
Scott Kitterman
25b2eb72b2
Merge remote-tracking branch 'jbfzs/beautifold'
2018-12-23 01:54:39 -05:00
Scott Kitterman
903cc902d9
Changelog and version for starting 0.9.2
2018-12-11 14:36:45 -05:00
Scott Kitterman
84efc4a1cb
Release 0.9.1
2018-12-09 14:10:44 -05:00
Scott Kitterman
72f58200e3
- Refactored dknewkey so that it correctly writes out text instead of bytes
2018-12-08 17:32:56 -05:00
Scott Kitterman
c3eb342611
Fixed ARC verification to fail is h= tag is present in Arc-Seal, added test, bumped version to start 0.9.1
2018-11-09 19:58:11 -05:00
Scott Kitterman
d659c496e5
Set release date
2018-10-30 11:57:17 -04:00
Scott Kitterman
267e62115e
- Added missing documentation for timestamp function dkim.arc_sign
...
(LP: #1800314 )
2018-10-30 11:52:43 -04:00
Scott Kitterman
09d4c3d84d
Fix @since for add_should_not
2018-10-30 11:40:20 -04:00
Scott Kitterman
8032276b57
Bump version to 0.9.0 since this is now a feature release
...
- Update oversigned (frozen) header field list to reduce signature
fragility (removes 'date' and 'subject' fields from being oversigned by
default - see usage section of README for information on how to restore
the previous behavior)
- Added new add_should_not for DKIM/ARC classes to prevent additional
header fields from being signed
- Added 'from' to should sign list (to prevent it from not being signed at
all in the unusual event that 'from' is locally removed from the frozen
header field set (LP: #1525048 )
- Updates for experimental ARC support:
- Specified that for ARC, Authentication-Results should not be signed
2018-10-30 11:29:09 -04:00
Scott Kitterman
82d01d8a42
- Raise error when ARC signing if i= instance limit value of 50 is
...
exceeded
2018-10-30 08:55:32 -04:00
Scott Kitterman
cd0ebc1ecb
- Updates for experimental ARC support:
...
- Limit to rsa-sha256, rsa-sha1 not used by ARC and multi-signature
design TBD
2018-10-30 08:13:06 -04:00
Scott Kitterman
3aaa7e2ab5
Bump versions to 0.8.2
2018-10-30 07:17:10 -04:00
Scott Kitterman
5349a9f813
Add support for EAI addresses in domains and selectors (John Levine)
2018-10-29 21:55:12 -04:00
Scott Kitterman
3a2e5fef61
Delete unused copy of dnsplug.py
2018-10-29 21:49:39 -04:00
Scott Kitterman
3c2beaf70e
- Python 3.7 compatibility fixup for dkim.canonicalization.
...
strip_trailing_lines due to changed RE.sub() processing (LP: #1800313 )
2018-10-29 19:53:12 -04:00
Scott Kitterman
b81797bc70
Add Changelog entries for Thomas Ward last two changes
2018-10-29 19:48:44 -04:00
Scott Kitterman
45266f6f05
Correct requires invocation for py3dns
2018-06-16 21:30:53 -04:00
Scott Kitterman
f8deb49c0d
Don't error out in Python 3 if include headers is string (LP: #1776775 )
2018-06-16 18:18:45 -04:00
Scott Kitterman
36da46861b
Add ChangeLog entries for Daniel Hahler's fixes
2018-06-16 17:31:55 -04:00
Scott Kitterman
0566b9b4c1
- Correctly fold lines at or near the maximum line length (fix folding
...
zero length lines and adding a blank line and adding an exra cr/lf for
lines near max length (LP: #1717576 )
2018-06-16 16:59:39 -04:00
Scott Kitterman
ef80f037ca
Delete unused test data
2018-06-09 22:07:02 -04:00
Scott Kitterman
3a68a64836
Update tests so that both RSA and Ed25519 verifying test verifying dual signed message.
2018-06-02 01:19:24 -04:00
Scott Kitterman
a911d5eac5
Update .gitignore to also ignore pyc files/dirs for test code
2018-06-02 01:06:38 -04:00
Scott Kitterman
d5c4f69b27
Remove obsolete and incorrect test data
2018-06-02 01:04:29 -04:00
Scott Kitterman
31ee4e8f91
Set release date in Changelog
2018-05-18 19:49:11 -04:00
Scott Kitterman
a0ae8c24c5
Detect unknown algorithm in k= tag and raise an appropriate error, vice
...
failing with a traceback
2018-05-18 19:42:46 -04:00
Scott Kitterman
92608e79c4
Simplify error message for bad version (match what Google does)
2018-05-18 18:21:32 -04:00
Scott Kitterman
bec6869c78
Detect incorrect version in DKIM public key record (LP: #1763815 )
2018-05-18 18:17:30 -04:00
Scott Kitterman
261eb5f5eb
Add test for detecting bad version number in DKIM txt record
2018-05-18 17:04:50 -04:00
Scott Kitterman
3b28e86f15
Indicate that ed25519-sha256 is no longer experimental
2018-05-18 02:48:42 -04:00
Scott Kitterman
85c4fe2adf
- Fix typo in dknewky(1) for k= tag (Thanks to Andreas Schulze for
...
reporting)
2018-03-28 06:51:35 -04:00
Scott Kitterman
3020b0e6d6
- Use install_requires and extras_requires to document external
...
dependencies for dkimpy (LP: #1227526 )
2018-03-27 01:23:00 -04:00
Scott Kitterman
7efe59e907
more script typo fix
2018-03-27 00:48:08 -04:00
Scott Kitterman
8651323863
script typo fix
2018-03-27 00:46:27 -04:00
Scott Kitterman
558eb87364
Add dist to .gitignore
2018-03-26 03:35:41 -04:00
Scott Kitterman
e50d3907ae
Fixup script structure for entrypoints
2018-03-26 03:35:03 -04:00
Scott Kitterman
30062b3c2b
Update ChangeLog and README for setuptools
2018-03-25 22:42:26 -04:00
Scott Kitterman
d860dfd51e
Switch to setuptools/entrypoints from distutils/scripts
2018-03-25 22:39:20 -04:00
Scott Kitterman
30143421e5
Upated .gitignore for setuptools changes
2018-03-25 22:36:15 -04:00
Scott Kitterman
c674e53a15
Bump version to 0.8.0
2018-03-25 20:52:53 -04:00
Scott Kitterman
1d67fd3c4d
Add .gitignore to ignore binary python artifacts
2018-03-18 18:24:20 -04:00
Scott Kitterman
1cafbe7e03
Remove debug print statements in test suite
2018-02-17 13:56:47 -05:00
Scott Kitterman
b1adfa3e33
Update man/dknewkey.1 to mention use of k= with RSA and bump version for release.
2018-02-17 13:52:13 -05:00
Scott Kitterman
f6e9587857
Use correct h= tag in dknewnkey.py generated DKIM records for RSA
2018-02-17 13:34:47 -05:00
Scott Kitterman
9f9fe2625b
Add another RFC data based test
2018-02-12 13:45:26 -05:00
Scott Kitterman
43e56378c1
- Return an empty list (as expected) when no AR headers are found or no AR
...
arc stamps are found and the chain terminated (LP: #1748146 )
2018-02-11 19:39:51 -05:00
Scott Kitterman
1ac948299e
Delete stray print
2018-02-11 19:29:53 -05:00
Scott Kitterman
d097a5f523
- Update ed25519 tests, including using sample keys from RFC 8032 Section
...
7.1 and the sample message from RFC 6376
2018-02-11 19:26:04 -05:00
Scott Kitterman
c77f03fa74
Update README and Changelog for release.
2018-02-07 01:06:50 -05:00
Scott Kitterman
2ab2720dbe
Set 0.7.0 back to unreleased - need to wait for -09 draft
2018-02-05 17:44:42 -05:00
Scott Kitterman
ae20ad128f
Update README
2018-02-05 14:44:49 -05:00
Scott Kitterman
581a1cd3f6
Update release date for today
2018-02-05 14:34:07 -05:00
Scott Kitterman
dc772430f6
Update man pages for ed25519
2018-02-05 14:27:16 -05:00
Scott Kitterman
6bbbdf9b22
Update test data and test harness for test_verify_third_party - now it passes
2018-02-05 13:43:19 -05:00
Scott Kitterman
3209be62d1
Fix a= tag in ed25519 signatures (thanks to Jeremy Harris)
2018-02-05 11:28:05 -05:00
Scott Kitterman
3138f90077
Updated copyright statements
2018-02-05 04:05:41 -05:00
Scott Kitterman
077bf4813c
Self consistent, but not externally verified ed25519 based on draft-ietf-dcrup-dkim-crypto-08
2018-02-05 03:53:03 -05:00
Scott Kitterman
10e12c60d8
- Fix unbound local variable error when processing signatures with an x
...
tag, but no t tag (LP: #1739637 )
2017-12-21 16:35:42 -05:00
Scott Kitterman
6b80254bd9
Fix -v verbose reporting in dkimverify.py
2017-12-01 02:10:03 -05:00
Scott Kitterman
0c6fdbf7c6
- Add new test, test_implicit_k, to verify that RSA processing is still
...
correct when the optional k= tag is not present in the DKIM public key
record
2017-11-30 14:33:01 -05:00
Scott Kitterman
4d4dcf1a78
Start ed25519 - update dknewkey.py and README.
2017-11-21 09:48:22 -05:00
Scott Kitterman
16f5bd693c
Fix empty body canonicalization for relaxed canonicalization (LP: #1727319 )
2017-11-21 07:13:01 -05:00
Scott Kitterman
44146ed2de
Fix arcverify tag requirements (LP: #1710312 )
2017-11-18 23:34:50 -05:00
Scott Kitterman
04b1a8dddf
Reapply lost ARC updates
2017-11-18 20:38:47 -05:00
Scott Kitterman
18d95309f8
Update ChangeLog
2017-11-18 20:24:27 -05:00
Scott Kitterman
01a2f77481
Revert a bunch of rsafp stuff now that DCRUP isn't going to do rsafp
2017-11-18 20:17:35 -05:00
Scott Kitterman
939c3f8bba
Updated Changedlog and README.
2017-07-28 01:36:24 -04:00
Scott Kitterman
3f9660716e
Delete unused sys import
2017-07-28 01:32:25 -04:00
Scott Kitterman
c37fcf55e8
Merge Gene Shuman updates for ARC
2017-07-28 01:30:52 -04:00
Scott Kitterman
89e0d568b7
Fixed tense in current Changelog entry.
2017-06-23 18:30:35 -04:00
Scott Kitterman
c7782addd5
- Add generation of rsafp DKIM signatures per
...
draft-ietf-dcrup-dkim-crypto-02
2017-06-23 18:29:37 -04:00
Scott Kitterman
80f663f02c
Remove stray print left in dknew.py
2017-06-22 20:25:09 -04:00
Scott Kitterman
d7eb35c22c
Add test keys for sha256fp
2017-06-22 20:24:32 -04:00
Scott Kitterman
bd14c6e90a
Add generation of rsafp DNS records per draft-ietf-dcrup-dkim-crypto-02
2017-06-22 19:56:27 -04:00
Scott Kitterman
d65f66f9d1
Fix it harder
2017-06-22 18:36:10 -04:00
Scott Kitterman
b0d28ffaf1
Oops. Send key_type to ExtractDnsPublicKey
2017-06-22 18:09:55 -04:00
Scott Kitterman
ddc1cbd61f
- Update dknewkey.py to use argparse. Add --ktype option to specify
...
different key type options in anticipation of the DCRUP WG output.
2017-06-22 18:08:01 -04:00
Scott Kitterman
e06014404c
- For dknewkey.py make default to include h=sha256 in the DNS record to
...
exclude usage with sha1. Can be overriden.
2017-06-21 01:22:26 -04:00
Scott Kitterman
693996d5f6
Add command line option to dkimsign.py to select signing algorithm
2017-06-06 01:05:25 -04:00
Scott Kitterman
6fa3b80808
Improve dkimsign.py help message.
2017-06-06 00:54:05 -04:00
Scott Kitterman
62290322b6
Copyright update
2017-06-05 00:25:00 -04:00
Scott Kitterman
7f3033d30c
Switch dkimsign.py to use dkim.DKIM directly rather than via dkim.dkim
...
Coerce argparse arguements to bytes so python3 works too
2017-06-05 00:20:32 -04:00
Scott Kitterman
60a6fc356e
dkimsign.py: PEP-8 line lengths
2017-06-04 17:27:07 -04:00
Scott Kitterman
b99e029974
- Add command line options to dkimsign.py to select header and body
...
canonicalization algorithmns (LP: #1272724 )
2017-06-04 17:21:39 -04:00
Scott Kitterman
818a7f807e
- Port dkimsign.py to use argparse; now gives standard usage message and
...
is more extensible
2017-06-04 17:05:18 -04:00
Scott Kitterman
804580a4d9
Set up to start 0.7 development.
2017-06-04 14:26:02 -04:00
Scott Kitterman
d4a2b4e954
Version and date for release.
2017-05-31 09:00:29 -04:00
Scott Kitterman
c170fe5a1d
Changelog for reference updates.
2017-05-31 02:03:37 -04:00
Scott Kitterman
38664fab55
Check and update references to RFC 4871 to refer to RFC 6376.
2017-05-31 02:01:22 -04:00
Scott Kitterman
144886ae0b
Check and update references to RFC 3447 with RFC 8017
2017-05-31 01:51:21 -04:00
Scott Kitterman
6dd8ebf08d
Mention DCRUP working group relative to minimum key size in README.
2017-05-31 01:26:59 -04:00
Scott Kitterman
e14a4f3539
- Fixed problem with header folding that caused the first line to be
...
folded too long (Updated test test_add_body_length since l= tag is no
longer at the beginning of a line
2017-05-30 12:11:15 -04:00
Scott Kitterman
1f48edd73b
Add test case for Body length not cast as bytes
2017-03-02 19:18:02 -05:00
Scott Kitterman
cdbb60841a
Add test case for verification when should headers are signed (thanks to Geoffrey Lehée for the patch)
2017-03-02 19:08:27 -05:00
Scott Kitterman
ccb067c32b
Update README to indicate python3.4 works now (since that was fixed by the previous two commits)
2017-03-02 17:10:43 -05:00
Scott Kitterman
f92abcd144
Bump to 0.6.2 for the next dev cycle.
2017-01-27 18:53:43 -05:00
Scott Kitterman
5938a29f57
More version bumping and changelog update for release.
2017-01-27 18:46:37 -05:00