Scott Kitterman
|
c674e53a15
|
Bump version to 0.8.0
|
2018-03-25 20:52:53 -04:00 |
|
Scott Kitterman
|
1d67fd3c4d
|
Add .gitignore to ignore binary python artifacts
|
2018-03-18 18:24:20 -04:00 |
|
Scott Kitterman
|
1cafbe7e03
|
Remove debug print statements in test suite
|
2018-02-17 13:56:47 -05:00 |
|
Scott Kitterman
|
b1adfa3e33
|
Update man/dknewkey.1 to mention use of k= with RSA and bump version for release.
|
2018-02-17 13:52:13 -05:00 |
|
Scott Kitterman
|
f6e9587857
|
Use correct h= tag in dknewnkey.py generated DKIM records for RSA
|
2018-02-17 13:34:47 -05:00 |
|
Scott Kitterman
|
9f9fe2625b
|
Add another RFC data based test
|
2018-02-12 13:45:26 -05:00 |
|
Scott Kitterman
|
43e56378c1
|
- Return an empty list (as expected) when no AR headers are found or no AR
arc stamps are found and the chain terminated (LP: #1748146)
|
2018-02-11 19:39:51 -05:00 |
|
Scott Kitterman
|
1ac948299e
|
Delete stray print
|
2018-02-11 19:29:53 -05:00 |
|
Scott Kitterman
|
d097a5f523
|
- Update ed25519 tests, including using sample keys from RFC 8032 Section
7.1 and the sample message from RFC 6376
|
2018-02-11 19:26:04 -05:00 |
|
Scott Kitterman
|
c77f03fa74
|
Update README and Changelog for release.
|
2018-02-07 01:06:50 -05:00 |
|
Scott Kitterman
|
2ab2720dbe
|
Set 0.7.0 back to unreleased - need to wait for -09 draft
|
2018-02-05 17:44:42 -05:00 |
|
Scott Kitterman
|
ae20ad128f
|
Update README
|
2018-02-05 14:44:49 -05:00 |
|
Scott Kitterman
|
581a1cd3f6
|
Update release date for today
|
2018-02-05 14:34:07 -05:00 |
|
Scott Kitterman
|
dc772430f6
|
Update man pages for ed25519
|
2018-02-05 14:27:16 -05:00 |
|
Scott Kitterman
|
6bbbdf9b22
|
Update test data and test harness for test_verify_third_party - now it passes
|
2018-02-05 13:43:19 -05:00 |
|
Scott Kitterman
|
3209be62d1
|
Fix a= tag in ed25519 signatures (thanks to Jeremy Harris)
|
2018-02-05 11:28:05 -05:00 |
|
Scott Kitterman
|
3138f90077
|
Updated copyright statements
|
2018-02-05 04:05:41 -05:00 |
|
Scott Kitterman
|
077bf4813c
|
Self consistent, but not externally verified ed25519 based on draft-ietf-dcrup-dkim-crypto-08
|
2018-02-05 03:53:03 -05:00 |
|
Scott Kitterman
|
10e12c60d8
|
- Fix unbound local variable error when processing signatures with an x
tag, but no t tag (LP: #1739637)
|
2017-12-21 16:35:42 -05:00 |
|
Scott Kitterman
|
6b80254bd9
|
Fix -v verbose reporting in dkimverify.py
|
2017-12-01 02:10:03 -05:00 |
|
Scott Kitterman
|
0c6fdbf7c6
|
- Add new test, test_implicit_k, to verify that RSA processing is still
correct when the optional k= tag is not present in the DKIM public key
record
|
2017-11-30 14:33:01 -05:00 |
|
Scott Kitterman
|
4d4dcf1a78
|
Start ed25519 - update dknewkey.py and README.
|
2017-11-21 09:48:22 -05:00 |
|
Scott Kitterman
|
16f5bd693c
|
Fix empty body canonicalization for relaxed canonicalization (LP: #1727319)
|
2017-11-21 07:13:01 -05:00 |
|
Scott Kitterman
|
44146ed2de
|
Fix arcverify tag requirements (LP: #1710312)
|
2017-11-18 23:34:50 -05:00 |
|
Scott Kitterman
|
04b1a8dddf
|
Reapply lost ARC updates
|
2017-11-18 20:38:47 -05:00 |
|
Scott Kitterman
|
18d95309f8
|
Update ChangeLog
|
2017-11-18 20:24:27 -05:00 |
|
Scott Kitterman
|
01a2f77481
|
Revert a bunch of rsafp stuff now that DCRUP isn't going to do rsafp
|
2017-11-18 20:17:35 -05:00 |
|
Scott Kitterman
|
939c3f8bba
|
Updated Changedlog and README.
|
2017-07-28 01:36:24 -04:00 |
|
Scott Kitterman
|
3f9660716e
|
Delete unused sys import
|
2017-07-28 01:32:25 -04:00 |
|
Scott Kitterman
|
c37fcf55e8
|
Merge Gene Shuman updates for ARC
|
2017-07-28 01:30:52 -04:00 |
|
Scott Kitterman
|
89e0d568b7
|
Fixed tense in current Changelog entry.
|
2017-06-23 18:30:35 -04:00 |
|
Scott Kitterman
|
c7782addd5
|
- Add generation of rsafp DKIM signatures per
draft-ietf-dcrup-dkim-crypto-02
|
2017-06-23 18:29:37 -04:00 |
|
Scott Kitterman
|
80f663f02c
|
Remove stray print left in dknew.py
|
2017-06-22 20:25:09 -04:00 |
|
Scott Kitterman
|
d7eb35c22c
|
Add test keys for sha256fp
|
2017-06-22 20:24:32 -04:00 |
|
Scott Kitterman
|
bd14c6e90a
|
Add generation of rsafp DNS records per draft-ietf-dcrup-dkim-crypto-02
|
2017-06-22 19:56:27 -04:00 |
|
Scott Kitterman
|
d65f66f9d1
|
Fix it harder
|
2017-06-22 18:36:10 -04:00 |
|
Scott Kitterman
|
b0d28ffaf1
|
Oops. Send key_type to ExtractDnsPublicKey
|
2017-06-22 18:09:55 -04:00 |
|
Scott Kitterman
|
ddc1cbd61f
|
- Update dknewkey.py to use argparse. Add --ktype option to specify
different key type options in anticipation of the DCRUP WG output.
|
2017-06-22 18:08:01 -04:00 |
|
Scott Kitterman
|
e06014404c
|
- For dknewkey.py make default to include h=sha256 in the DNS record to
exclude usage with sha1. Can be overriden.
|
2017-06-21 01:22:26 -04:00 |
|
Scott Kitterman
|
693996d5f6
|
Add command line option to dkimsign.py to select signing algorithm
|
2017-06-06 01:05:25 -04:00 |
|
Scott Kitterman
|
6fa3b80808
|
Improve dkimsign.py help message.
|
2017-06-06 00:54:05 -04:00 |
|
Scott Kitterman
|
62290322b6
|
Copyright update
|
2017-06-05 00:25:00 -04:00 |
|
Scott Kitterman
|
7f3033d30c
|
Switch dkimsign.py to use dkim.DKIM directly rather than via dkim.dkim
Coerce argparse arguements to bytes so python3 works too
|
2017-06-05 00:20:32 -04:00 |
|
Scott Kitterman
|
60a6fc356e
|
dkimsign.py: PEP-8 line lengths
|
2017-06-04 17:27:07 -04:00 |
|
Scott Kitterman
|
b99e029974
|
- Add command line options to dkimsign.py to select header and body
canonicalization algorithmns (LP: #1272724)
|
2017-06-04 17:21:39 -04:00 |
|
Scott Kitterman
|
818a7f807e
|
- Port dkimsign.py to use argparse; now gives standard usage message and
is more extensible
|
2017-06-04 17:05:18 -04:00 |
|
Scott Kitterman
|
804580a4d9
|
Set up to start 0.7 development.
|
2017-06-04 14:26:02 -04:00 |
|
Scott Kitterman
|
d4a2b4e954
|
Version and date for release.
|
2017-05-31 09:00:29 -04:00 |
|
Scott Kitterman
|
c170fe5a1d
|
Changelog for reference updates.
|
2017-05-31 02:03:37 -04:00 |
|
Scott Kitterman
|
38664fab55
|
Check and update references to RFC 4871 to refer to RFC 6376.
|
2017-05-31 02:01:22 -04:00 |
|
Scott Kitterman
|
144886ae0b
|
Check and update references to RFC 3447 with RFC 8017
|
2017-05-31 01:51:21 -04:00 |
|
Scott Kitterman
|
6dd8ebf08d
|
Mention DCRUP working group relative to minimum key size in README.
|
2017-05-31 01:26:59 -04:00 |
|
Scott Kitterman
|
e14a4f3539
|
- Fixed problem with header folding that caused the first line to be
folded too long (Updated test test_add_body_length since l= tag is no
longer at the beginning of a line
|
2017-05-30 12:11:15 -04:00 |
|
Scott Kitterman
|
1f48edd73b
|
Add test case for Body length not cast as bytes
|
2017-03-02 19:18:02 -05:00 |
|
Scott Kitterman
|
cdbb60841a
|
Add test case for verification when should headers are signed (thanks to Geoffrey Lehée for the patch)
|
2017-03-02 19:08:27 -05:00 |
|
Scott Kitterman
|
ccb067c32b
|
Update README to indicate python3.4 works now (since that was fixed by the previous two commits)
|
2017-03-02 17:10:43 -05:00 |
|
Scott Kitterman
|
f92abcd144
|
Bump to 0.6.2 for the next dev cycle.
|
2017-01-27 18:53:43 -05:00 |
|
Scott Kitterman
|
5938a29f57
|
More version bumping and changelog update for release.
|
2017-01-27 18:46:37 -05:00 |
|
Scott Kitterman
|
e9bf999385
|
Bump versions to 0.6.1 for start of development
|
2017-01-23 18:22:01 -05:00 |
|
Scott Kitterman
|
7f28c44e81
|
Fix ARC draft revision
|
2017-01-23 13:21:18 -05:00 |
|
Scott Kitterman
|
2714ae344d
|
Update Changelog.
|
2017-01-23 13:19:01 -05:00 |
|
Scott Kitterman
|
a7608bf907
|
Typo fix for dknewkey.py
|
2017-01-23 13:17:16 -05:00 |
|
Scott Kitterman
|
067ae3e3d3
|
Add man pages for arcsign, arcverify, and dknewkey.
|
2017-01-23 13:16:37 -05:00 |
|
Scott Kitterman
|
73be935774
|
Update setup.py and MANIFEST for new scripts
|
2017-01-23 12:35:50 -05:00 |
|
Scott Kitterman
|
8fb9c46046
|
README typo.
|
2017-01-23 12:27:22 -05:00 |
|
Scott Kitterman
|
1ded8e9171
|
Pre-release version bumps and documentation updates.
|
2017-01-23 12:18:26 -05:00 |
|
Scott Kitterman
|
1de815367c
|
Add mention of online documentation to README.
|
2017-01-23 10:38:17 -05:00 |
|
Scott Kitterman
|
02c1265bb9
|
Add ARC testing information to README.
|
2017-01-20 14:35:15 -05:00 |
|
Scott Kitterman
|
f3666578ee
|
Valimail ARC integration
|
2017-01-18 01:09:14 -05:00 |
|
Scott Kitterman
|
697d55d057
|
Work in progress to better integrate ARC into dkimpy
|
2016-11-12 23:18:48 -05:00 |
|
Scott Kitterman
|
baf8d8e417
|
Commit ARC changes from Brandon Long <[email protected]>
- These will need some rework to integrate into the packcage - we do not want to ship two modules
|
2016-10-14 16:37:56 -04:00 |
|
Scott Kitterman
|
db448f1630
|
Clean up local tree so release is clean and then do a quick 0.5.6.
|
2015-12-07 17:44:01 -05:00 |
|
Scott Kitterman
|
b0ac6f6224
|
Remove PKG-INFO stub from bzr tree as it is generated as part of the sdist and does not need to be manually manitained.
|
2015-12-07 17:15:03 -05:00 |
|
Scott Kitterman
|
135103376a
|
Add Changelog entries for 0.5.5 and bump version to 0.5.5.
|
2015-12-07 17:10:31 -05:00 |
|
Scott Kitterman
|
fd0caddf16
|
Update for version 0.5.4.
Fixed error in FWS regular expression that cause some valid signatures
fail verification (Thanks to Peter Palfrader (weasel) for the patch)
|
2013-06-09 22:43:29 -04:00 |
|
Scott Kitterman
|
a5e10c1a98
|
- Change dkimsign.py to sign the default (recommended) set of headers
instead of all headers
|
2013-04-29 01:01:00 -04:00 |
|
Scott Kitterman
|
5c9f52b0c1
|
Add test case for message with no 5322.From - Should get ParameterError and fail to sign.
|
2013-04-28 15:24:38 -04:00 |
|
Scott Kitterman
|
02551e35b2
|
- Update changelog and versions to start 0.5.3.
- Improve key error messages to help troubleshooting.
|
2012-07-21 01:44:06 -04:00 |
|
Scott Kitterman
|
9fd21038e6
|
Fix Python 3 classifier in setup.py
|
2012-06-13 00:59:18 -04:00 |
|
Scott Kitterman
|
e0511c4629
|
Fix typo in package name in setup.py.
|
2012-06-13 00:55:43 -04:00 |
|
Scott Kitterman
|
59a112fe9c
|
Fix MANIFEST.in for recursion.
|
2012-06-13 00:51:07 -04:00 |
|
Scott Kitterman
|
34a0ef7675
|
Add MANIFEST.in for pypi.
|
2012-06-13 00:47:50 -04:00 |
|
Scott Kitterman
|
0514c5aa34
|
Bump versions to 0.5.2 and add Changelog for 0.5.2.
|
2012-06-13 00:28:10 -04:00 |
|
Scott Kitterman
|
2f8798a859
|
Fix incorrect variable in verify logger function.
|
2012-03-17 22:02:30 -04:00 |
|
Scott Kitterman
|
9f9358f30f
|
Add pypi trove classifiers to setup.py
|
2012-02-04 10:23:01 -05:00 |
|
Scott Kitterman
|
be3a6dbe83
|
Changes for pydkim -> dkimpy
|
2012-02-03 19:05:34 -05:00 |
|
Scott Kitterman
|
77cd2cae35
|
Remove obsolete publish.sh script.
|
2011-06-17 08:58:21 -05:00 |
|
Scott Kitterman
|
3e5e1a06aa
|
* Remove version in shebang in dkimsign.py and dkimverify.py
* Remove obsolete dkimsend.sh
|
2011-06-16 23:08:20 -05:00 |
|
Scott Kitterman
|
550e3e3983
|
Update version numbers to 0.5 and start new Changelog entry.
|
2011-06-16 22:41:42 -05:00 |
|
Scott Kitterman
|
18e9aef36b
|
Update Changelog and switch to version 0.4.2 throughout.
|
2011-06-16 14:50:03 -05:00 |
|
Scott Kitterman
|
8713e6e9f8
|
Move dkim/dns.py to dkim/dnsplug.py to stay clear of dnspython dns namespace.
|
2011-06-16 14:47:45 -05:00 |
|
Scott Kitterman
|
86077755b2
|
Update versions to 0.4.1 and correct/update Changelog.
|
2011-06-15 08:49:20 -05:00 |
|
Scott Kitterman
|
4ab054860f
|
Fix package version in PKG-INFO and README.
|
2011-06-15 00:18:16 -05:00 |
|
Scott Kitterman
|
6ceace530e
|
merge lp:~mbp/pydkim/587783-relaxed
|
2011-03-15 02:00:59 -04:00 |
|
Scott Kitterman
|
00164b8b5c
|
* Change py_modules to packages in setup.py so it will install correctly.
* Explicitly mark all files modified from the original upstream (licensing paranoia).
|
2011-03-15 00:10:03 -04:00 |
|
Scott Kitterman
|
25d3294b30
|
* Add man page install to setup.py.
|
2011-03-08 01:24:27 -05:00 |
|
Scott Kitterman
|
9e6246cc35
|
* Add man directory and dkimsign.1/dkimverify.1 from Debian package.
|
2011-03-07 23:33:23 -05:00 |
|
Scott Kitterman
|
009a0bc15e
|
* Fix incorrect key record validation failures due to invalid assumptions about
public key record requirements
* Remove extraneous dkim.py.orig file
|
2011-03-07 23:28:10 -05:00 |
|
Scott Kitterman
|
4cc38d62fd
|
Start with pydkim 0.3.
|
2011-03-07 23:25:49 -05:00 |
|